User Tools

Site Tools


services:satellite

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revisionPrevious revision
Next revision
Previous revision
services:satellite [2022/07/13 00:35] – djgallowayservices:satellite [2023/11/30 19:57] (current) – [Summary] dmick
Line 6: Line 6:
  
 **Web Login**: https://satellite.front.sepia.ceph.com\\ **Web Login**: https://satellite.front.sepia.ceph.com\\
-**Username**: root\\+**Username**: admin\\
 **Password**: Standard root password **Password**: Standard root password
  
Line 135: Line 135:
  
 ===== Errors and Fixes ===== ===== Errors and Fixes =====
 +==== Error: Loading repository 'rhel-8-for-x86_64-baseos-rpms' has failed ====
 +If RHEL clients are failing to perform yum/dnf transactions, check ''dmesg -T'' output on the Satellite server for OOM.
 +
 +<code>
 +[root@smithi077 ~]# dnf -v update
 +Loaded plugins: builddep, changelog, config-manager, copr, debug, debuginfo-install, download, generate_completion_cache, groups-manager, kpatch, needs-restarting, playground, product-id, repoclosure, repodiff, repograph, repomanage, reposync, subscription-manager, uploadprofile
 +Updating Subscription Management repositories.
 +DNF version: 4.7.0
 +cachedir: /var/cache/dnf
 +User-Agent: constructed: 'libdnf (Red Hat Enterprise Linux 8.6; generic; Linux.x86_64)'
 +repo: using cache for: copr:copr.fedorainfracloud.org:ceph:python3-asyncssh
 +copr:copr.fedorainfracloud.org:ceph:python3-asyncssh: using metadata from Tue 27 Jul 2021 07:25:39 PM UTC.
 +repo: using cache for: epel
 +epel: using metadata from Tue 09 Aug 2022 02:13:36 AM UTC.
 +repo: using cache for: lab-extras
 +lab-extras: using metadata from Thu 28 Jan 2021 11:16:50 PM UTC.
 +Red Hat Enterprise Linux 8 for x86_64 - AppStream (RPMs)                                                                                                                                                                                        157 kB/s | 2.8 kB     00:00    
 +reviving: 'rhel-8-for-x86_64-appstream-rpms' can be revived - repomd matches.
 +rhel-8-for-x86_64-appstream-rpms: using metadata from Mon 08 Aug 2022 05:07:41 AM UTC.
 +Red Hat Enterprise Linux 8 for x86_64 - BaseOS (RPMs)                                                                                                                                                                                            89 kB/s | 1.5 kB     00:00    
 +reviving: 'rhel-8-for-x86_64-baseos-rpms' can be revived - repomd matches.
 +loading repo 'rhel-8-for-x86_64-baseos-rpms' failure: loading of MD_TYPE_PRIMARY has failed.
 +Error: Loading repository 'rhel-8-for-x86_64-baseos-rpms' has failed
 +</code>
 +
 +After you resolve the OOM issue, you will need to resync the repository.  If BaseOS is the one that was failing:
 +<code>
 +for id in $(hammer -c /etc/hammer/cli.modules.d/foreman.yml repository list | grep -i "baseos" | awk '{ print $1 }'); do hammer -c /etc/hammer/cli.modules.d/foreman.yml repository synchronize --async --validate-contents true --id $id; done
 +</code>
 +
 ==== Unable to verify server's identity: [SSL: TLSV1_ALERT_UNKNOWN_CA] tlsv1 alert unknown ca (_ssl.c:618) ==== ==== Unable to verify server's identity: [SSL: TLSV1_ALERT_UNKNOWN_CA] tlsv1 alert unknown ca (_ssl.c:618) ====
 <code> <code>
Line 165: Line 195:
 None of this actually ended up working so... None of this actually ended up working so...
  
-====== DO NOT UPGRADE TO SATELLITE 6.5 ======+====== Solved On SATELLITE 6.12 ======
  
 +Despite this, in Jan 2023 we had to install a new Satellite instance, and it's version 6.12; this was chosen for allowing continued support, but initially suffered from the same issue.  A support case, https://access.redhat.com/support/cases/#/case/03399123, was opened to deal with it and the solution was this - https://github.com/ceph/ceph-cm-ansible/pull/717
 +https://github.com/ceph/ceph-cm-ansible/pull/718
services/satellite.1657672513.txt.gz · Last modified: by djgalloway